2. Configuration mode of network devices

General user mode: usually there is a sharp angle symbol> after the name of the network device, this mode can only view the configuration information, The device cannot be configured, this is the minimum permission to access the device.

Privileged user mode: Enter enable in normal user mode to enter privileged user mode. At this time, there is a # sign after the name of the network device. In this mode, you can access network devices, modify configuration commands, restart the router and view Configuration file running status, etc. Enter disable to return to normal user mode.

Global configuration mode: In privileged configuration mode, enter configure terminal to enter global configuration mode, which is the (config)# mark after the network device name. The global mode is like a garden in a garden. After entering the zoo, if you want to see specific precious animals, you have to buy tickets to enter.

Interface configuration mode: In global mode, enter interface + interface (ethernet 1/0) to enter interface configuration mode, which is the (config-if)# mark after the network device name, the configuration here Only valid for this interface.

Route configuration mode: In global mode, enter router + routing protocol to enter route configuration mode, this is the network device name with (config-router)# mark number,

line Configuration mode: In global mode, enter line + line number to enter interface configuration mode, which is the (config-line)# mark after the network device name,

Three, commonly used routing configuration Commands

1. Enter privileged mode enable

router > enable
router #

2. Enter global Configuration mode configure terminal
router > enable
router #configure terminal
router (config)#

3. Rename hostname routera Take routerA as an example
router > enable
router #configure terminal
router(config)#hostname routerA
routerA (config)#

4. Configure the enable password enable password cisco to cisco For example
router > enable
router #configure terminal
router(config)#hostname routerA
routerA (config)# enable password cisco

5. Configure the enable password enable secret ciscolab Take cicsolab as an example
router > enable
router #configure terminal
router(config)#hostname routerA
routerA (config)# enable secret ciscolab

6. Enter a port of the router interface fastethernet 0/1
router > enable
router #configure terminal
router(config)#hostname router A
routerA (config)# interface fastethernet 0/1
routerA (config-if)#
Enter a certain subport of the router interface fastethernet 0/1.1 The 1 subport of 1 port is Example
router > enable
router #configure terminal
router(config)#hostname routerA
routerA(config)# interface fastehernet 0/1.1

7 . Set the port ip address information
router > enable
router #configure terminal
router(config)#hostname routerA
routerA(config)# interface fastethernet 0/1 with 1 port For example
routerA (config-if)#ip address 192.168.1.1 255.255.255.0 configure switch port ip and subnet mask
routerA (config-if)#no shut start this interface
routerA (config-if)#exit

8. View the command show
router > enable
router # show version View all version information in the system
show serial controllers + No. View the serial port type
show ip route View the routing table of the router

9. cdp related commands
router > enable
router # show cdp View the cdp global configuration of the device Information
show cdp traffic View statistics about cdp packets
show cdp neighbors List cisco devices connected to the device

10. Password recovery for csico2600
Reboot the router , press ctrl+break during startup to make the router enter rom monitor mode.
Enter the command at the prompt to modify the value of the configuration register, and then restart the router.
rommon1>confreg 0×2142
rommon2>reset
After restarting the router, enter the setup mode, select "no", and return to the exec mode. At this time, the original configuration of the router is still saved in the startup In -config, in order to keep the configuration unchanged after the router recovers the password, you need to save the configuration in the startup-config to the running-config, then reset the enable password, and change the value of the configuration register back to 0×2102.
router>enable
router#copy startup-config running-config
router#configure terminal
router(config)#enable password cisco
router(config)#config -register 0×2102
Save the current configuration to startup-config , restart the router.
router #copy running-config startup-config
router #reload

11. Router telnet remote login settings
router>en
router #configure terminal< br/>router (config)#hostname routerA
routerA (config)#enable password cisco use cisco as the privileged mode password
routerA (config)#interface fastethernet 0/1
routerA (config- if)#ip address 192.168.1.1 255.255.255.0
routerA (config-if)#no shut
routerA (config-if)#exit
routerA (config)line vty 0 4 set 0 -4 users can telnet remote login
routerA (config-line)#password 123
routerA (config-line)#login

12. Configure the router's ID banner $… …………$
Using the "banner" command in the global configuration mode can configure the prompt information of the router, and all terminals connected to the router will receive it.
router>en
router #configure terminal
router (config)#hostname routerA
routerA(config)#banner motd $This is aptech company' router ! Please don't change the configuration without permission!$

13. Configure the interface identifier description …………
The interface identifier is used to distinguish each interface of the router. These flags can be viewed with the show run command.
router>en
router #configure terminal
router (config)#hostname routerA
routerA(config)#interface fastethernet 0/1 Take interface 0/1 as an example
routerA(config-if)# description this is a fast Ethernet port used to connecting the company's intranet!

14. Configuration timeout
Timeout is used to set how long the console is not configured , which automatically returns the exec session time. The default is 10 minutes.
router>en
router #configure terminal
router (config)#hostname routerA
routerA(config)#line console 0
routerA(config-line)#exec -timeout 0 0 The first "0" represents minutes, the second "0" represents seconds

15. Configure serial port parameters
Two routers need to be connected through serial ports as DTE and one as DTE. as DCE. DCE equipment provides clock frequency and bandwidth to DTE equipment.
DCE configuration:
router>en
router #configure terminal
router (config)#hostname routerA
routerA(config)#interface serial 0/0
routerA(config-if)#clock rate 64000 provides a clock rate of 64000
routerA(config-if)#bandwidth 64 provides a bandwidth of 64
routerA(config-if)#no shut
DTE configuration:
router>en
router #configure terminal
router (config)#hostname routerB
routerB(config)#interface serial 0/0
routerB(config -if)#no shut

16. Static routing configuration
Configure the name and interface parameters of router R1
router>enable
router#configure terminal
router(config)#hostname routerA
routerA(config)#interface fastethernet 0/0
routerA(config-if)#ip address 192.168.2.1 255.255.255.0
routerA(config-if) #no shutdown
routerA(config-if)#exit
routerA(config)# interface fastethernet 0/1
routerA(config-if)#ip address 192.168.3.1 255.255.255.0
routerA(config-if)#no shutdown
The ip address of host A is 192.168.3.2
255.255.255.0
192.168.3.1
Configure the name and interface parameters of router R2
/>router>enable
router#configure terminal
router(config)#hostname routerB
routerB(config)#interface fastethernet 0/0
routerB(config-if)#ip address 192.168.2.2 255.255.255.0
routerB(config-if)#no shutdown
routerB(config-if)#exit
routerB(config)# interface fastethernet 0/1
routerB(config-if)#ip address 192.168.1.1 255.255.255.0
The ip address of host B is 192.168.1.2
255.255.255.0
192.168.1.1
Configure router R1 Static routing table
routerA(config)#ip router 192.168.1.0 255.255.255.0 192.168.2.2
Configure the static routing table of router R2
routerA(config)#ip router 192.168.3.0 255.255. 255.0 192.168.2.1
Configure default routes on R1 and R2
routerA(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.2
routerA(config)#ip classless
routerB(config)#ip route 0.0.0 .0 0.0.0.0 192.168.2.1
routerB(config)#ip classless (supports variable-length subnet masks, classless inter-domain routing)
Configure dynamic routing (RIP) on routerA and routerB< br/>routerA(config)#router rip
routerA(config)#network 192.168.2.0
routerA(config)#network 192.168.3.0
routerB(config)# router rip
routerB(config)#network 192.168.2.0
routerB(config)#network 192.168.1.0

17. Configure one-arm routing

router(config )# interface f0/0.1

router(config-subif)# ip address 192.168.1.1 255.255.255.0

router(config-subif)# encapsulation dot1q 1

< p>router(config-subif)# exit

router(config)# interface f0/0.2

router(config-subif)# ip address 192.168.2.1 255.255.255.0

p>

router(config-subif)# encapsulation dot1q 2

router(config-subif)# exit

router(config)# interface f0/0.3

router(config-subif)# ip address 192.168.3.1 255.255.255.0

router(config-subif)# encapsulation dot1q 3

router(config-subif)# exit

router(config)# interface f0/0

router(config-if)# no shut

CCNP-300-710-SNCF-Dumps

Applying for IT certification requires choosing the certification, studying for the exam, and passing it. ITCertDumps could possibly be your finest ally if you’re considering obtaining a certification. ITCertDumps supplies the CCNP 300-710 SNCF Dumps and may ensure a 100% pass rate.

Comments

Leave a comment